summaryrefslogtreecommitdiffstats
path: root/klines/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitc90c389a8a8d9d8661e9772ec4144c5cf2039f23 (patch)
tree6d8391395bce9eaea4ad78958617edb20c6a7573 /klines/Makefile.am
downloadtdegames-c90c389a8a8d9d8661e9772ec4144c5cf2039f23.tar.gz
tdegames-c90c389a8a8d9d8661e9772ec4144c5cf2039f23.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdegames@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'klines/Makefile.am')
-rw-r--r--klines/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/klines/Makefile.am b/klines/Makefile.am
new file mode 100644
index 00000000..37c8a6ec
--- /dev/null
+++ b/klines/Makefile.am
@@ -0,0 +1,27 @@
+
+INCLUDES= -I$(top_srcdir)/libkdegames -I$(top_srcdir)/libkdegames/highscore $(all_includes)
+METASOURCES = AUTO
+
+bin_PROGRAMS = klines
+klines_SOURCES = prompt.cpp mwidget.cpp linesboard.cpp field.cpp cell.cpp \
+ ballpainter.cpp klines.cpp main.cpp prefs.kcfgc
+klines_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+klines_LDADD = $(LIB_KDEGAMES)
+klines_DEPENDENCIES = $(LIB_KDEGAMES_DEP)
+
+picsdir = $(kde_datadir)/klines/
+pics_DATA = balls.jpg field.jpg fire.jpg
+
+xdg_apps_DATA = klines.desktop
+kde_kcfg_DATA = klines.kcfg
+
+EXTRA_DIST = $(pics_DATA)
+
+KDE_ICON = klines
+
+rcdir = $(kde_datadir)/klines
+rc_DATA = klinesui.rc
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/klines.pot;
+