summaryrefslogtreecommitdiffstats
path: root/kspaceduel/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kspaceduel/CMakeLists.txt')
-rw-r--r--kspaceduel/CMakeLists.txt47
1 files changed, 47 insertions, 0 deletions
diff --git a/kspaceduel/CMakeLists.txt b/kspaceduel/CMakeLists.txt
new file mode 100644
index 00000000..8775757f
--- /dev/null
+++ b/kspaceduel/CMakeLists.txt
@@ -0,0 +1,47 @@
+# This file is genereted by trinity-automake-cmake-convert script by Fat-Zer
+
+add_subdirectory( sprites )
+add_subdirectory( pics )
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/libtdegames
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### kspaceduel (executable) ###################
+
+tde_add_executable( kspaceduel AUTOMOC
+ SOURCES general.ui mathroutines.cpp topwidget.cpp playerinfo.cpp sprites.cpp
+ mainview.cpp dialogs.cpp ai.cpp main.cpp options.kcfgc
+ LINK tdecore-shared tdeui-shared tdeio-shared tdegames-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### icons #####################################
+
+tde_install_icons( kspaceduel )
+
+
+##### other data ################################
+
+install( FILES kspaceduel.desktop
+ DESTINATION ${XDG_APPS_INSTALL_DIR}
+)
+
+install( FILES kspaceduelui.rc
+ DESTINATION ${DATA_INSTALL_DIR}/kspaceduel
+)
+
+install( FILES kspaceduel.kcfg
+ DESTINATION ${KCFG_INSTALL_DIR}
+)