summaryrefslogtreecommitdiffstats
path: root/kooka/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit47d455dd55be855e4cc691c32f687f723d9247ee (patch)
tree52e236aaa2576bdb3840ebede26619692fed6d7d /kooka/Makefile.am
downloadtdegraphics-47d455dd55be855e4cc691c32f687f723d9247ee.tar.gz
tdegraphics-47d455dd55be855e4cc691c32f687f723d9247ee.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdegraphics@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kooka/Makefile.am')
-rw-r--r--kooka/Makefile.am46
1 files changed, 46 insertions, 0 deletions
diff --git a/kooka/Makefile.am b/kooka/Makefile.am
new file mode 100644
index 00000000..6fec098e
--- /dev/null
+++ b/kooka/Makefile.am
@@ -0,0 +1,46 @@
+## Makefile.am for kooka
+
+SUBDIRS = pics
+
+bin_PROGRAMS = kooka
+METASOURCES = AUTO
+
+kooka_SOURCES = main.cpp kooka.cpp kookaview.cpp kookapref.cpp \
+ img_saver.cpp ksaneocr.cpp \
+ kookaimage.cpp kookaimagemeta.cpp scanpackager.cpp \
+ imgnamecombo.cpp imageselectline.cpp \
+ thumbview.cpp thumbviewitem.cpp \
+ dwmenuaction.cpp kocrbase.cpp \
+ kocrgocr.cpp kocrkadmos.cpp kadmosocr.cpp ocrword.cpp \
+ ocrresedit.cpp kookaprint.cpp imgprintdialog.cpp \
+ kocrocrad.cpp
+# pagesetup.cpp
+
+kooka_LDADD = $(LIB_KFILE) -lkdeprint -lktexteditor $(LIBTIFF) $(top_builddir)/libkscan/libkscan.la $(KADMOS_LIB) $(LIB_KSPELL)
+kooka_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+
+INCLUDES = -I$(top_srcdir)/libkscan $(all_includes) $(LIBSANE_INCLUDES) $(KADMOS_INC)
+
+noinst_HEADERS = \
+kookaview.h scanpackager.h \
+img_saver.h ksaneocr.h \
+formathelp.h kooka.h \
+kookaiface.h thumbview.h thumbviewitem.h \
+kookapref.h resource.h \
+imgnamecombo.h imageselectline.h kookaimage.h kookaimagemeta.h \
+kocrbase.h kocrgocr.h kocrkadmos.h \
+kadmosocr.h ocrword.h ocrresedit.h kookaprint.h imgprintdialog.h \
+kocrocrad.h
+
+# pagesetup.h
+
+appdatadir = $(kde_datadir)/kooka
+appdata_DATA = kookaui.rc
+
+kde_conf_DATA = kookarc
+
+xdg_apps_DATA = kooka.desktop
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kooka.pot
+