summaryrefslogtreecommitdiffstats
path: root/ksnapshot/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit47d455dd55be855e4cc691c32f687f723d9247ee (patch)
tree52e236aaa2576bdb3840ebede26619692fed6d7d /ksnapshot/Makefile.am
downloadtdegraphics-47d455dd55be855e4cc691c32f687f723d9247ee.tar.gz
tdegraphics-47d455dd55be855e4cc691c32f687f723d9247ee.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdegraphics@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'ksnapshot/Makefile.am')
-rw-r--r--ksnapshot/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/ksnapshot/Makefile.am b/ksnapshot/Makefile.am
new file mode 100644
index 00000000..a9dae435
--- /dev/null
+++ b/ksnapshot/Makefile.am
@@ -0,0 +1,21 @@
+bin_PROGRAMS= ksnapshot
+
+INCLUDES = -DKSNAPVERSION="\"0.7\"" $(all_includes)
+
+ksnapshot_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+ksnapshot_LDADD = $(LIB_KDEPRINT)
+
+ksnapshot_SOURCES = ksnapshotiface.skel main.cpp ksnapshot.cpp \
+ regiongrabber.cpp windowgrabber.cpp ksnapshotwidget.ui
+
+ksnapshot_METASOURCES = AUTO
+
+xdg_apps_DATA = ksnapshot.desktop
+
+KDE_ICON = ksnapshot
+
+EXTRA_DIST = $(xdg_apps_DATA)
+
+messages: rc.cpp
+ $(XGETTEXT) rc.cpp *.cpp -o $(podir)/ksnapshot.pot
+