summaryrefslogtreecommitdiffstats
path: root/kview/modules/browser/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-09 17:49:10 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-09 19:55:02 +0200
commit605ad91b1690a8149c2f351d1838f2d3c6929106 (patch)
tree8a1b07dd03802c1359a6409f0bab8a6d89ef87d3 /kview/modules/browser/CMakeLists.txt
parent766134636125fd2ed1c1a1b97fdd7f63f5bf3ed7 (diff)
downloadtdegraphics-605ad91b1690a8149c2f351d1838f2d3c6929106.tar.gz
tdegraphics-605ad91b1690a8149c2f351d1838f2d3c6929106.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 837dbafbea0c7f7bc73d27fda684ea2dededd547)
Diffstat (limited to 'kview/modules/browser/CMakeLists.txt')
-rw-r--r--kview/modules/browser/CMakeLists.txt14
1 files changed, 11 insertions, 3 deletions
diff --git a/kview/modules/browser/CMakeLists.txt b/kview/modules/browser/CMakeLists.txt
index efa48578..b1b26f6c 100644
--- a/kview/modules/browser/CMakeLists.txt
+++ b/kview/modules/browser/CMakeLists.txt
@@ -23,9 +23,17 @@ link_directories(
##### other data ################################
-install( FILES
- kviewbrowser.desktop kviewbrowser.rc
- DESTINATION ${DATA_INSTALL_DIR}/kviewviewer/kpartplugins )
+tde_create_translated_desktop(
+ SOURCE kviewbrowser.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/kviewviewer/kpartplugins
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/kview-desktops
+)
+
+install(
+ FILES
+ kviewbrowser.rc
+ DESTINATION ${DATA_INSTALL_DIR}/kviewviewer/kpartplugins
+)
##### kview_browserplugin (module) ##############