summaryrefslogtreecommitdiffstats
path: root/tdefile-plugins/bmp/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:03:37 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:03:37 -0600
commit2e25fa39cd67cca2472d3eabdb478feb517d72a5 (patch)
tree63725962f632d152cbf20709191d39f6fc865966 /tdefile-plugins/bmp/Makefile.am
parent190d88dfc662f3fc466c9d1f53acbbea65f33c49 (diff)
downloadtdegraphics-2e25fa39cd67cca2472d3eabdb478feb517d72a5.tar.gz
tdegraphics-2e25fa39cd67cca2472d3eabdb478feb517d72a5.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdefile-plugins/bmp/Makefile.am')
-rw-r--r--tdefile-plugins/bmp/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/tdefile-plugins/bmp/Makefile.am b/tdefile-plugins/bmp/Makefile.am
new file mode 100644
index 00000000..f8f70112
--- /dev/null
+++ b/tdefile-plugins/bmp/Makefile.am
@@ -0,0 +1,22 @@
+## Makefile.am for bmp file meta info plugin
+
+# set the include path for X, qt and KDE
+INCLUDES = $(all_includes)
+
+# these are the headers for your project
+noinst_HEADERS = tdefile_bmp.h
+
+kde_module_LTLIBRARIES = tdefile_bmp.la
+
+tdefile_bmp_la_SOURCES = tdefile_bmp.cpp
+tdefile_bmp_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+tdefile_bmp_la_LIBADD = $(LIB_KSYCOCA)
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) tdefile_bmp.cpp -o $(podir)/tdefile_bmp.pot
+
+services_DATA = tdefile_bmp.desktop
+servicesdir = $(kde_servicesdir)