summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 7 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0c6ff909..a48f5976 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -43,11 +43,13 @@ tde_setup_paths( )
##### optional stuff ############################
-option( WITH_T1LIB "Enable t1lib support" OFF )
-option( WITH_PAPER "Enable libpaper support" OFF )
-OPTION( WITH_TIFF "Enable tiff support (tdefile-plugins)" OFF )
-OPTION( WITH_OPENEXR "Enable openexr support (tdefile-plugins)" OFF )
-OPTION( WITH_PDF "Enable pdf support (tdefile-plugins)" OFF )
+OPTION( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+
+option( WITH_T1LIB "Enable t1lib support" ${WITH_ALL_OPTIONS} )
+option( WITH_PAPER "Enable libpaper support" ${WITH_ALL_OPTIONS} )
+OPTION( WITH_TIFF "Enable tiff support (tdefile-plugins)" ${WITH_ALL_OPTIONS} )
+OPTION( WITH_OPENEXR "Enable openexr support (tdefile-plugins)" ${WITH_ALL_OPTIONS} )
+OPTION( WITH_PDF "Enable pdf support (tdefile-plugins)" ${WITH_ALL_OPTIONS} )
##### options comments ##########################