summaryrefslogtreecommitdiffstats
path: root/ksnapshot/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ksnapshot/CMakeLists.txt')
-rw-r--r--ksnapshot/CMakeLists.txt45
1 files changed, 45 insertions, 0 deletions
diff --git a/ksnapshot/CMakeLists.txt b/ksnapshot/CMakeLists.txt
new file mode 100644
index 00000000..b5d5fd3e
--- /dev/null
+++ b/ksnapshot/CMakeLists.txt
@@ -0,0 +1,45 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include( ConfigureChecks.cmake )
+
+add_definitions(
+ -DKSNAPVERSION="0.7"
+)
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+tde_install_icons( ksnapshot )
+install( FILES ksnapshot.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
+
+
+##### ksnapshot (executable) ####################
+
+tde_add_executable( ksnapshot AUTOMOC
+ SOURCES
+ ksnapshotiface.skel main.cpp ksnapshot.cpp regiongrabber.cpp
+ windowgrabber.cpp ksnapshotwidget.ui
+ LINK kdeprint-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)