summaryrefslogtreecommitdiffstats
path: root/ksnapshot/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ksnapshot/Makefile.am')
-rw-r--r--ksnapshot/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/ksnapshot/Makefile.am b/ksnapshot/Makefile.am
new file mode 100644
index 00000000..a9dae435
--- /dev/null
+++ b/ksnapshot/Makefile.am
@@ -0,0 +1,21 @@
+bin_PROGRAMS= ksnapshot
+
+INCLUDES = -DKSNAPVERSION="\"0.7\"" $(all_includes)
+
+ksnapshot_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+ksnapshot_LDADD = $(LIB_KDEPRINT)
+
+ksnapshot_SOURCES = ksnapshotiface.skel main.cpp ksnapshot.cpp \
+ regiongrabber.cpp windowgrabber.cpp ksnapshotwidget.ui
+
+ksnapshot_METASOURCES = AUTO
+
+xdg_apps_DATA = ksnapshot.desktop
+
+KDE_ICON = ksnapshot
+
+EXTRA_DIST = $(xdg_apps_DATA)
+
+messages: rc.cpp
+ $(XGETTEXT) rc.cpp *.cpp -o $(podir)/ksnapshot.pot
+