summaryrefslogtreecommitdiffstats
path: root/ksvg/plugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ksvg/plugin/CMakeLists.txt')
-rw-r--r--ksvg/plugin/CMakeLists.txt10
1 files changed, 7 insertions, 3 deletions
diff --git a/ksvg/plugin/CMakeLists.txt b/ksvg/plugin/CMakeLists.txt
index 08078eb5..360bae35 100644
--- a/ksvg/plugin/CMakeLists.txt
+++ b/ksvg/plugin/CMakeLists.txt
@@ -39,9 +39,13 @@ install( FILES
##### other data ################################
-install( FILES
- ksvgplugin.desktop svgthumbnail.desktop
- DESTINATION ${SERVICES_INSTALL_DIR} )
+foreach( _service ksvgplugin.desktop svgthumbnail.desktop )
+ tde_create_translated_desktop(
+ SOURCE ${_service}
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/ksvg-desktops
+ )
+endforeach()
install( FILES
ksvgplugin.rc