summaryrefslogtreecommitdiffstats
path: root/kview/modules/template/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kview/modules/template/Makefile.am')
-rw-r--r--kview/modules/template/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/kview/modules/template/Makefile.am b/kview/modules/template/Makefile.am
new file mode 100644
index 00000000..29ddc94c
--- /dev/null
+++ b/kview/modules/template/Makefile.am
@@ -0,0 +1,15 @@
+INCLUDES = -I$(top_srcdir)/kview $(all_includes)
+
+kde_module_LTLIBRARIES = kview_templateplugin.la
+
+kview_templateplugin_la_SOURCES = kviewtemplate.cpp
+kview_templateplugin_la_LIBADD = $(LIB_KFILE) $(LIB_KPARTS) -lkdeprint
+kview_templateplugin_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+
+plugdir = $(kde_datadir)/kview/kpartplugins
+plug_DATA = kviewtemplate.desktop kviewtemplate.rc
+
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp *.h -o $(podir)/kviewtemplateplugin.pot