summaryrefslogtreecommitdiffstats
path: root/tdefile-plugins/pdf/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tdefile-plugins/pdf/CMakeLists.txt')
-rw-r--r--tdefile-plugins/pdf/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/tdefile-plugins/pdf/CMakeLists.txt b/tdefile-plugins/pdf/CMakeLists.txt
new file mode 100644
index 00000000..5a81d453
--- /dev/null
+++ b/tdefile-plugins/pdf/CMakeLists.txt
@@ -0,0 +1,36 @@
+#################################################
+#
+# (C) 2010-2011 Calvin Morrison
+# mutantturkey@gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_SOURCE_DIR}/tdefile-plugins/dependencies/poppler-tqt
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+#### other data #################################
+
+install( FILES tdefile_pdf.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+
+
+#### tdefile_pdf (module) #########################
+
+tde_add_kpart( tdefile_pdf AUTOMOC
+ SOURCES tdefile_pdf.cpp
+ LINK tdeio-shared -L${CMAKE_BINARY_DIR}/tdefile-plugins/dependencies/poppler-tqt -lpoppler-tqt
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)