summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOBATA Akio <obache@wizdas.com>2020-08-16 18:15:33 +0900
committerSlávek Banko <slavek.banko@axis.cz>2021-02-03 22:37:07 +0100
commit3241cab0cf421f41c6872f3212d3b80375612757 (patch)
treedeb0dca8907cf1c897dd5cf0b868b081b32015c2 /CMakeLists.txt
parent75aaa51fe2d63a0258522ca44b88215093893c6e (diff)
downloadtdelibs-3241cab0cf421f41c6872f3212d3b80375612757.tar.gz
tdelibs-3241cab0cf421f41c6872f3212d3b80375612757.zip
Allow to use backtrace(3) external library for kdebug
Signed-off-by: OBATA Akio <obache@wizdas.com> (cherry picked from commit 2167207adc49b498536a5a8533c27fc67e0c6e9c)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 12 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1252f8461..621382177 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -317,7 +317,18 @@ check_symbol_exists( gethostbyname2_r "netdb.h" HAVE_GETHOSTBYNAME2_R )
check_symbol_exists( gethostbyname_r "netdb.h" HAVE_GETHOSTBYNAME_R )
check_symbol_exists( gai_strerror "sys/types.h;sys/socket.h;netdb.h" HAVE_GAI_STRERROR )
check_symbol_exists( getaddrinfo "sys/types.h;sys/socket.h;netdb.h" HAVE_GETADDRINFO )
-check_symbol_exists( backtrace "execinfo.h" HAVE_BACKTRACE )
+if ( CMAKE_MAJOR_VERSION LESS "3" )
+ check_symbol_exists( backtrace "execinfo.h" HAVE_BACKTRACE )
+ if ( HAVE_BACKTRACE )
+ set ( Backtrace_LIBRARY "" )
+ set ( Backtrace_HEADER "execinfo.h" )
+ endif ()
+else ()
+ find_package( Backtrace )
+ if ( Backtrace_FOUND )
+ set ( HAVE_BACKTRACE 1 )
+ endif ()
+endif ()
check_cxx_source_compiles( "#include <cxxabi.h>
int main() { abi::__cxa_demangle(0, 0, 0, 0); return 0; }"
HAVE_ABI_CXA_DEMANGLE )