summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-01-15 16:54:53 -0600
committerSlávek Banko <slavek.banko@axis.cz>2012-06-02 19:05:18 +0200
commitbea964028bf3b0b8b0f4dfabd7e7652e39941571 (patch)
treefd12f530422fdb42c495c79efeffa19bafbf794d /CMakeLists.txt
parent422f8fa037a1b8fadb6ec54da265025da7edaca2 (diff)
downloadtdelibs-bea964028bf3b0b8b0f4dfabd7e7652e39941571.tar.gz
tdelibs-bea964028bf3b0b8b0f4dfabd7e7652e39941571.zip
Add fam/gamin support to tdelibs CMake
(cherry picked from commit 2b035349c31fe64c31d2c050892b117a3a807179)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c8508c810..1ba2d84cc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -77,6 +77,7 @@ OPTION( WITH_UTEMPTER "Use utempter for utmp management" OFF )
OPTION( WITH_AVAHI "Enable AVAHI support" OFF )
OPTION( WITH_PCRE "Enable pcre regex support for kjs" ON )
OPTION( WITH_INOTIFY "Enable inotify support for kio" ON )
+OPTION( WITH_GAMIN "Enable FAM/GAMIN support" ${WITH_ALL_OPTIONS} )
OPTION( WITH_ASPELL "Enable aspell support" OFF )
OPTION( WITH_HSPELL "Enable hspell support" OFF )
@@ -747,6 +748,23 @@ if( WITH_INOTIFY )
endif( )
+##### check for FAM/GAMIN ##########################
+
+if( WITH_GAMIN )
+ check_include_file( "fam.h" HAVE_FAM_H )
+ if( HAVE_FAM_H )
+ pkg_search_module( GAMIN gamin )
+ if( GAMIN_FOUND )
+ set( HAVE_FAM 1 )
+ else( GAMIN_FOUND )
+ message(FATAL_ERROR "\nfam/gamin support was requested, but gamin was not found on your system" )
+ endif( GAMIN_FOUND )
+ else( HAVE_FAM_H )
+ message(FATAL_ERROR "\nfam/gamin support was requested, but fam was not found on your system" )
+ endif( HAVE_FAM_H )
+endif( WITH_GAMIN )
+
+
##### check for aspell ##########################
# we need ASPELL_DATADIR too