summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-04-18 18:58:23 -0500
committerSlávek Banko <slavek.banko@axis.cz>2013-04-25 03:22:57 +0200
commitc3a7e5d3db985190b00321cb4d760a25a461eff0 (patch)
treefb640b5fe8e52608754286dd2c5f02ffe57e5b2f /CMakeLists.txt
parent3ab7d7ba97776bdb079d743abe75f65957a77179 (diff)
downloadtdelibs-c3a7e5d3db985190b00321cb4d760a25a461eff0.tar.gz
tdelibs-c3a7e5d3db985190b00321cb4d760a25a461eff0.zip
Fix URL handling of media/builtin-* mimetypes
This partially resolves Bug 976 Add missing ACL support to CMake build files (cherry picked from commit 30b0af1f01cdbfcc51a56943e8c091bc8991f83a)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c2a021258..be57552a8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -167,6 +167,7 @@ check_include_file( "stdlib.h" HAVE_STDLIB_H )
check_include_file( "strings.h" HAVE_STRINGS_H )
check_include_file( "string.h" HAVE_STRING_H )
check_include_file( "sysent.h" HAVE_SYSENT_H )
+check_include_file( "sys/acl.h" HAVE_SYS_ACL_H )
check_include_file( "sys/bitypes.h" HAVE_SYS_BITYPES_H )
check_include_file( "sys/dir.h" HAVE_SYS_DIR_H )
check_include_file( "sys/filio.h" HAVE_SYS_FILIO_H )
@@ -183,7 +184,7 @@ check_include_file( "sys/stat.h" HAVE_SYS_STAT_H )
check_include_file( "sys/stropts.h" HAVE_SYS_STROPTS_H )
check_include_file( "sys/types.h" HAVE_SYS_TYPES_H )
check_include_file( "sys/ucred.h" HAVE_SYS_UCRED_H )
-check_include_file( "sys/xattr.h" sys/xattr.h )
+check_include_file( "sys/xattr.h" HAVE_SYS_XATTR_H )
check_include_file( "termios.h" HAVE_TERMIOS_H )
check_include_file( "termio.h" HAVE_TERMIO_H )
check_include_file( "unistd.h" HAVE_UNISTD_H )
@@ -197,6 +198,12 @@ if( HAVE_SYS_TIME_H AND HAVE_TIME_H )
set( TIME_WITH_SYS_TIME 1 )
endif( HAVE_SYS_TIME_H AND HAVE_TIME_H )
+if( HAVE_SYS_ACL_H )
+ set( USE_POSIX_ACL 1 )
+endif( HAVE_SYS_ACL_H )
+
+check_include_file( "acl/libacl.h" HAVE_NON_POSIX_ACL_EXTENSIONS )
+
check_include_file( "valgrind/memcheck.h" HAVE_VALGRIND_MEMCHECK_H )
check_include_file( "values.h" HAVE_VALUES_H )
check_include_file( "X11/extensions/shape.h" HAVE_X11_EXTENSIONS_SHAPE_H )