summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2015-06-11 02:38:01 +0200
committerSlávek Banko <slavek.banko@axis.cz>2015-12-23 02:22:59 +0100
commitfb74d787f16652987a6376ecb77a67d01b7325ff (patch)
treef76a8fb0e8b8331616209fae476df305ab7f3c1a /CMakeLists.txt
parent7746d2f9c1dca6fdb5084d7c48f852f9015cf15d (diff)
downloadtdelibs-fb74d787f16652987a6376ecb77a67d01b7325ff.tar.gz
tdelibs-fb74d787f16652987a6376ecb77a67d01b7325ff.zip
Add include directory for internal libltdl
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit dfd680030c18adaa4f299a4092d9ac6d5945cadc)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7013f8adf..bc23c12b4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -140,10 +140,12 @@ endif( NO_BUILTIN )
##### system checks #############################
+tde_save_and_set( CMAKE_REQUIRED_INCLUDES ${CMAKE_SOURCE_DIR}/libltdl )
check_include_file( "ltdl.h" HAVE_LTDL_H )
if( NOT HAVE_LTDL_H )
- tde_message_fatal( "ltdl.h are required, but not found on your system" )
+ tde_message_fatal( "ltdl.h is required, but not found on your system" )
endif( )
+tde_restore( CMAKE_REQUIRED_INCLUDES )
check_include_file( "alloca.h" HAVE_ALLOCA_H )
check_include_file( "arpa/nameser8_compat.h" HAVE_ARPA_NAMESER8_COMPAT_H )