summaryrefslogtreecommitdiffstats
path: root/kdeaccounts-plugin/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitbd9e6617827818fd043452c08c606f07b78014a0 (patch)
tree425bb4c3168f9c02f10150f235d2cb998dcc6108 /kdeaccounts-plugin/Makefile.am
downloadtdesdk-bd9e6617827818fd043452c08c606f07b78014a0.tar.gz
tdesdk-bd9e6617827818fd043452c08c606f07b78014a0.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdesdk@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kdeaccounts-plugin/Makefile.am')
-rw-r--r--kdeaccounts-plugin/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/kdeaccounts-plugin/Makefile.am b/kdeaccounts-plugin/Makefile.am
new file mode 100644
index 00000000..7be8cea3
--- /dev/null
+++ b/kdeaccounts-plugin/Makefile.am
@@ -0,0 +1,17 @@
+INCLUDES = $(all_includes)
+
+noinst_HEADERS = kdeaccountsformat.h
+kde_module_LTLIBRARIES = kabcformat_kdeaccounts.la
+kabcformat_kdeaccounts_la_SOURCES = kdeaccountsformat.cpp
+kabcformat_kdeaccounts_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+kabcformat_kdeaccounts_la_LIBADD = -lkabc
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kabcformat_kdeaccounts.pot
+
+linkdir = $(kde_datadir)/kabc/formats
+link_DATA = kdeaccountsplugin.desktop
+EXTRA_DIST = $(link_DATA) README