summaryrefslogtreecommitdiffstats
path: root/kompare/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitbd9e6617827818fd043452c08c606f07b78014a0 (patch)
tree425bb4c3168f9c02f10150f235d2cb998dcc6108 /kompare/Makefile.am
downloadtdesdk-bd9e6617827818fd043452c08c606f07b78014a0.tar.gz
tdesdk-bd9e6617827818fd043452c08c606f07b78014a0.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdesdk@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kompare/Makefile.am')
-rw-r--r--kompare/Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/kompare/Makefile.am b/kompare/Makefile.am
new file mode 100644
index 00000000..bf5297b5
--- /dev/null
+++ b/kompare/Makefile.am
@@ -0,0 +1,43 @@
+SUBDIRS = interfaces libdiff2 libdialogpages komparenavtreepart komparepart pics
+
+INCLUDES = \
+ -I$(srcdir)/libdiff2 \
+ -I$(srcdir)/libdialogpages \
+ -I$(srcdir)/komparenavtreepart \
+ -I$(srcdir)/komparepart \
+ -I$(srcdir)/interfaces \
+ $(all_includes)
+
+noinst_HEADERS = kompare_shell.h kompareurldialog.h
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(EXTRACTRC) */*.rc */*.ui >> rc.cpp
+ $(XGETTEXT) `find . -name "*.cpp" -o -name "*.h"` -o $(podir)/kompare.pot
+
+#########################################################################
+# APPLICATION SECTION
+#########################################################################
+# this is the program that gets installed. it's name is used for all
+# of the other Makefile.am variables
+bin_PROGRAMS = kompare
+
+# the application source, library search path, and link libraries
+kompare_SOURCES = main.cpp kompare_shell.cpp kompareurldialog.cpp
+kompare_LDFLAGS = $(all_libraries)
+kompare_LDADD = $(LIB_KPARTS) \
+ $(top_builddir)/kompare/interfaces/libkompareinterface.la \
+ $(top_builddir)/kompare/libdialogpages/libdialogpages.la \
+ -lktexteditor
+
+# this is where the desktop file will go
+xdg_apps_DATA = kompare.desktop
+
+# this is where the shell's XML-GUI resource file goes
+shellrcdir = $(kde_datadir)/kompare
+shellrc_DATA = kompareui.rc
+
+kompareservicedir = $(kde_servicetypesdir)
+kompareservice_DATA = komparenavigationpart.desktop kompareviewpart.desktop