summaryrefslogtreecommitdiffstats
path: root/kbabel/common/libgettext/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kbabel/common/libgettext/Makefile.am')
-rw-r--r--kbabel/common/libgettext/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/kbabel/common/libgettext/Makefile.am b/kbabel/common/libgettext/Makefile.am
new file mode 100644
index 00000000..eca54fda
--- /dev/null
+++ b/kbabel/common/libgettext/Makefile.am
@@ -0,0 +1,15 @@
+# this might be a naive way of seeing it, but
+# automake does not support C++ flex files.
+#LEX_OUTPUT_ROOT = lex.GettextBase
+#AM_LFLAGS = -+
+
+CLEANFILES = pofiles.cc
+
+noinst_LTLIBRARIES = libgettext.la
+
+libgettext_la_SOURCES = pofiles.cc
+
+pofiles.cc: $(srcdir)/pofiles.ll
+ $(LEX) -+ -opofiles.cc $(srcdir)/pofiles.ll
+
+noinst_HEADERS = tokens.h pofiles.h