summaryrefslogtreecommitdiffstats
path: root/kbugbuster/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kbugbuster/Makefile.am')
-rw-r--r--kbugbuster/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/kbugbuster/Makefile.am b/kbugbuster/Makefile.am
new file mode 100644
index 00000000..44b31733
--- /dev/null
+++ b/kbugbuster/Makefile.am
@@ -0,0 +1,28 @@
+INCLUDES= -I$(top_srcdir)/kbugbuster/backend $(all_includes)
+
+if include_kcalresource
+KRESOURCES_SUBDIR = kresources
+endif
+
+SUBDIRS = backend gui pics $(KRESOURCES_SUBDIR)
+
+bin_PROGRAMS = kbugbuster
+
+kbugbuster_SOURCES = main.cpp
+kbugbuster_LDADD = -lkutils gui/libkbbmainwindow.la \
+ backend/libkbbbackend.la $(LIB_KHTML) $(LIB_KIO)
+kbugbuster_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+
+xdg_apps_DATA = kbugbuster.desktop
+
+KDE_ICON = kbugbuster
+
+METASOURCES = AUTO
+
+EXTRA_DIST = AUTHORS COPYING ChangeLog INSTALL README TODO kbugbuster.lsm
+
+messages: rc.cpp
+ $(EXTRACTRC) */*.kcfg >> rc.cpp
+ $(EXTRACTRC) gui/*.rc >> rc.cpp
+ $(EXTRACTRC) gui/*.ui >> rc.cpp
+ $(XGETTEXT) *.cpp */*.h */*.cpp -o $(podir)/kbugbuster.pot