summaryrefslogtreecommitdiffstats
path: root/kdeaccounts-plugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kdeaccounts-plugin/CMakeLists.txt')
-rw-r--r--kdeaccounts-plugin/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/kdeaccounts-plugin/CMakeLists.txt b/kdeaccounts-plugin/CMakeLists.txt
new file mode 100644
index 00000000..2a144863
--- /dev/null
+++ b/kdeaccounts-plugin/CMakeLists.txt
@@ -0,0 +1,34 @@
+#################################################
+#
+# (C) 2012 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES kdeaccountsplugin.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/kabc/formats )
+
+
+##### kabcformat_kdeaccounts (module) ###########
+
+tde_add_kpart( kabcformat_kdeaccounts
+ SOURCES kdeaccountsformat.cpp
+ LINK kabc-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)