summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-01-16 14:39:07 +0000
committersamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-01-16 14:39:07 +0000
commit039cc9f8f7c3b81ca85336b02efa49e8e26dbacd (patch)
tree5de007445ec5416ecbc4c2db1696870d124596b2 /CMakeLists.txt
parent7af884d886e2428d5b28e9cf7d81c97d7e378123 (diff)
downloadtdewebdev-039cc9f8f7c3b81ca85336b02efa49e8e26dbacd.tar.gz
tdewebdev-039cc9f8f7c3b81ca85336b02efa49e8e26dbacd.zip
[kdewebdev/quanta] initial cmake support
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdewebdev@1214824 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt82
1 files changed, 82 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 00000000..6edbed73
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,82 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+cmake_minimum_required( VERSION 2.6 )
+
+
+##### general package setup #####################
+
+project( kdewebdev )
+
+
+##### include essential cmake modules ###########
+
+include( CheckCXXSourceCompiles )
+include( CheckFunctionExists )
+include( CheckIncludeFileCXX )
+include( CheckStructHasMember )
+include( CheckSymbolExists )
+include( CheckTypeSize )
+include( FindPkgConfig )
+
+
+##### include our cmake modules #################
+
+set( CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake/modules" )
+include( TDEMacros )
+
+
+##### setup install paths #######################
+
+include( TDESetupPaths )
+tde_setup_paths( )
+
+
+##### optional stuff ############################
+
+# option( WITH_LIBVISUAL "Enable libvisual support" OFF )
+# option( WITH_KONQSIDEBAR "Enable konqsidebar plugin" OFF )
+# option( WITH_XINE "Enable xine-engine support" OFF )
+# option( WITH_LIBGPOD "Enable iPod support from libgpod" OFF )
+
+
+##### user requested modules ####################
+
+option( BUILD_ALL "Build all" OFF )
+option( BUILD_QUANTA "Build Quanta" ${BUILD_ALL} )
+
+
+##### configure checks ##########################
+
+include( ConfigureChecks.cmake )
+
+
+###### global compiler settings #################
+
+add_definitions(
+ -DHAVE_CONFIG_H
+ ${TQT_CFLAGS_OTHER}
+)
+
+set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -include tqt.h" )
+set( CMAKE_SHARED_LINKER_FLAGS "-Wl,--no-undefined" )
+set( CMAKE_MODULE_LINKER_FLAGS "-Wl,--no-undefined" )
+
+
+##### source directories ########################
+
+add_subdirectory( lib )
+tde_conditional_add_subdirectory( BUILD_QUANTA quanta )
+
+
+##### write configure files #####################
+
+configure_file( config.h.cmake config.h @ONLY )