summaryrefslogtreecommitdiffstats
path: root/quanta/plugins/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'quanta/plugins/Makefile.am')
-rw-r--r--quanta/plugins/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/quanta/plugins/Makefile.am b/quanta/plugins/Makefile.am
new file mode 100644
index 00000000..bdbdd141
--- /dev/null
+++ b/quanta/plugins/Makefile.am
@@ -0,0 +1,15 @@
+noinst_LTLIBRARIES = libplugins.la
+
+METASOURCES = AUTO
+
+libplugins_la_SOURCES = quantaplugininterface.cpp quantaplugineditor.cpp quantapluginconfig.cpp quantaplugin.cpp plugineditor.ui pluginconfig.ui
+
+AM_CPPFLAGS = -I$(top_srcdir)/quanta/utility \
+ -I$(top_srcdir)/quanta/parsers \
+ -I$(top_srcdir)/quanta/src \
+ -I$(top_srcdir)/quanta/project \
+ -I$(top_srcdir)/quanta/messages \
+ -I$(top_srcdir)/lib \
+ $(KMDI_INCLUDES) $(all_includes)
+
+