summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-03-21 14:24:49 +0100
committerSlávek Banko <slavek.banko@axis.cz>2020-03-23 20:16:00 +0100
commitfea7ebd27462042547048589a490a5fc87c7ef34 (patch)
tree7337264c528e9f2915ad46b3c488e9b9cb9703cc /src/CMakeLists.txt
parenta52c922703f7aaaf12777ebd06ad2a25861552eb (diff)
downloadabakus-fea7ebd27462042547048589a490a5fc87c7ef34.tar.gz
abakus-fea7ebd27462042547048589a490a5fc87c7ef34.zip
Desktop file translations:
+ Creation of POT templates for desktop files added to CMakeL10n rules. + Added creation of translated desktop file during build. + The abakus.desktop will be installed to the XDG_APPS_INSTALL_DIR. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit a1a48db571e6fa1c3ae94a22546548b87e497dd2)
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index a7365d2..be6ddd2 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -23,11 +23,14 @@ link_directories(
include( ${CMAKE_SOURCE_DIR}/BisonMacros.cmake )
+
##### other data ################################
-install( FILES abakus.desktop DESTINATION ${APPS_INSTALL_DIR}/Utilities )
+tde_create_translated_desktop( abakus.desktop )
+
install( FILES abakusui.rc DESTINATION ${DATA_INSTALL_DIR}/abakus )
+
##### abakus (executable) #######################
GENERATE_BISON_FLEX_SOURCES(${CMAKE_SOURCE_DIR}/src/parser.yy "" ${CMAKE_SOURCE_DIR}/src/lexer.ll "")