summaryrefslogtreecommitdiffstats
path: root/akode/plugins/src_resampler/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'akode/plugins/src_resampler/CMakeLists.txt')
-rw-r--r--akode/plugins/src_resampler/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/akode/plugins/src_resampler/CMakeLists.txt b/akode/plugins/src_resampler/CMakeLists.txt
new file mode 100644
index 0000000..6489dc3
--- /dev/null
+++ b/akode/plugins/src_resampler/CMakeLists.txt
@@ -0,0 +1,31 @@
+#################################################
+#
+# (C) 2015 Slávek Banko
+# slavek (DOT) banko (AT) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}/akode/lib
+ ${CMAKE_SOURCE_DIR}/akode/lib
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+)
+
+
+##### library ###################################
+
+set( target libakode_src_resampler )
+
+tde_add_library(
+ ${target} MODULE
+ SOURCES src_resampler.cpp
+ LINK akode-shared ${SAMPLERATE_LIBRARIES}
+ DESTINATION ${LIB_INSTALL_DIR}
+)
+