summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-01-10 01:16:09 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-01-10 01:16:09 -0600
commit4c08c66641779bd7d14fc68dde22af8f08603712 (patch)
tree70deeb1684b9480604632a001653ac9181286cc2 /CMakeLists.txt
parent7d1ddd67f4d66d34a6615d4020fc079ffed09cde (diff)
downloadarts-4c08c66641779bd7d14fc68dde22af8f08603712.tar.gz
arts-4c08c66641779bd7d14fc68dde22af8f08603712.zip
Add gcc visibility option to arts
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b442d86..a75fed8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -33,6 +33,7 @@ option( WITH_ALSA "Enable ALSA support" ON )
option( WITH_AUDIOFILE "Enable audiofile (wav) support" ON )
option( WITH_VORBIS "Enable Ogg/Vorbis support" ON )
option( WITH_MAD "Enable MAD mp3 decoder support" ON )
+option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" OFF )
##### paths setup ###############################
@@ -159,6 +160,20 @@ else( GLIB2_FOUND )
endif( GLIB2_FOUND )
+##### check for gcc visibility support #########
+# FIXME
+# This should check for [T]Qt3 visibility support
+
+if( WITH_GCC_VISIBILITY )
+ if( NOT UNIX )
+ message(FATAL_ERROR "\ngcc visibility support was requested, but your system is not *NIX" )
+ endif( NOT UNIX )
+ set( __KDE_HAVE_GCC_VISIBILITY 1 )
+ set( CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fvisibility=hidden -fvisibility-inlines-hidden")
+ set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fvisibility=hidden -fvisibility-inlines-hidden")
+endif( )
+
+
##### check for TQt #############################
include( CheckCXXSourceCompiles )