summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-01-12 17:29:01 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-01-12 17:29:01 -0600
commitc85bc12559cbeaa3e18544a459adab147267007e (patch)
treef23da27b33ef336c362dc947f47cb95c608ac95c /CMakeLists.txt
parentd548013bdb885cac474191d0efdda85685417f08 (diff)
downloadarts-c85bc12559cbeaa3e18544a459adab147267007e.tar.gz
arts-c85bc12559cbeaa3e18544a459adab147267007e.zip
Add jack support to CMake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 44d83d1..7b6230f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -35,6 +35,7 @@ option( WITH_AUDIOFILE "Enable audiofile (wav) support" ON )
option( WITH_VORBIS "Enable Ogg/Vorbis support" ON )
option( WITH_MAD "Enable MAD mp3 decoder support" ON )
option( WITH_ESOUND "Enable ESOUND support" ${WITH_ALL_OPTIONS} )
+option( WITH_JACK "Enable JACK support" ${WITH_ALL_OPTIONS} )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
@@ -165,6 +166,19 @@ if( WITH_ESOUND )
endif( WITH_ESOUND )
+##### check for JACK ############################
+
+set( HAVE_LIBJACK 0 )
+if( WITH_JACK )
+ pkg_search_module( LIBJACK jack )
+ if( LIBJACK_FOUND )
+ set( HAVE_LIBJACK 1 )
+ else( LIBJACK_FOUND )
+ message(FATAL_ERROR "\nJACK support is requested, but `jack.pc` was not found" )
+ endif( LIBJACK_FOUND )
+endif( WITH_JACK )
+
+
##### check for glib/gthread modules ############
pkg_search_module( GLIB2 glib-2.0 )