summaryrefslogtreecommitdiffstats
path: root/artsc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'artsc/CMakeLists.txt')
-rw-r--r--artsc/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/artsc/CMakeLists.txt b/artsc/CMakeLists.txt
index bddde63..c462250 100644
--- a/artsc/CMakeLists.txt
+++ b/artsc/CMakeLists.txt
@@ -31,10 +31,14 @@ foreach( INC ${GTHREAD2_INCLUDE_DIRS} )
set( GLIB_CFLAGS "${GLIB_CFLAGS} -I${INC}" )
endforeach(INC)
+configure_file( artsc.pc.in artsc.pc @ONLY )
configure_file( artsc-config.in artsc-config @ONLY )
configure_file( artsdsp.in artsdsp @ONLY )
configure_file( artsc_export.h.in artsc_export.h @ONLY )
+install( FILES ${CMAKE_CURRENT_BINARY_DIR}/artsc.pc
+ DESTINATION ${PKGCONFIG_INSTALL_DIR} )
+
install( PROGRAMS
${CMAKE_CURRENT_BINARY_DIR}/artsdsp
${CMAKE_CURRENT_BINARY_DIR}/artsc-config