summaryrefslogtreecommitdiffstats
path: root/artsc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'artsc/CMakeLists.txt')
-rw-r--r--artsc/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/artsc/CMakeLists.txt b/artsc/CMakeLists.txt
index 59833c1..71f8baa 100644
--- a/artsc/CMakeLists.txt
+++ b/artsc/CMakeLists.txt
@@ -17,8 +17,10 @@ add_definitions( -DCOMPILING_ARTSC )
set( prefix ${CMAKE_INSTALL_PREFIX} )
set( exec_prefix $prefix )
set( libdir ${LIB_INSTALL_DIR} )
-set( includedir ${INCLUDE_INSTALL_DIR} )
-set( LIBDL -l${DL_LIBRARIES} )
+set( includedir ${CMAKE_INSTALL_PREFIX}/include/artsc )
+if( NOT "${DL_LIBRARIES}" STREQUAL "" )
+ set( LIBDL -l${DL_LIBRARIES} )
+endif( )
set( USE_THREADS )
set( LIBPTHREAD ${CMAKE_THREAD_LIBS_INIT} )
foreach( LIB ${GTHREAD2_LIBRARIES} )
@@ -57,7 +59,7 @@ include_directories(
# FIXME: DESTINATION is currently a workaround
install( FILES
artsc.h ${CMAKE_CURRENT_BINARY_DIR}/artsc_export.h
- DESTINATION ${CMAKE_INSTALL_PREFIX}/include/artsc )
+ DESTINATION ${includedir} )
##### artsdsp (shared lib) ######################