summaryrefslogtreecommitdiffstats
path: root/gmcop/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gmcop/CMakeLists.txt')
-rw-r--r--gmcop/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/gmcop/CMakeLists.txt b/gmcop/CMakeLists.txt
new file mode 100644
index 0000000..f49c194
--- /dev/null
+++ b/gmcop/CMakeLists.txt
@@ -0,0 +1,34 @@
+#################################################
+#
+# (C) 2010 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+set( gmcop_INCS
+ giomanager.h
+)
+
+set( gmcop_SRCS
+ giomanager.cc
+)
+
+include_directories(
+ ${CMAKE_BINARY_DIR}/mcop # for arts_export.h
+ ${CMAKE_SOURCE_DIR}/mcop # for iomanager.h, etc.
+ ${GLIB2_INCLUDE_DIRS}
+)
+
+add_library( gmcop SHARED ${gmcop_SRCS} )
+set_target_properties( gmcop PROPERTIES VERSION 1.0 SOVERSION 1 )
+target_link_libraries( gmcop mcop ${GLIB2_LIBRARIES} )
+
+
+##### install ###################################
+
+install( FILES ${gmcop_INCS} DESTINATION ${INCLUDE_INSTALL_DIR} )
+install(TARGETS gmcop LIBRARY DESTINATION ${LIB_INSTALL_DIR} ) \ No newline at end of file