summaryrefslogtreecommitdiffstats
path: root/kontact_plugin/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kontact_plugin/Makefile.am')
-rw-r--r--kontact_plugin/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/kontact_plugin/Makefile.am b/kontact_plugin/Makefile.am
new file mode 100644
index 0000000..1a63eea
--- /dev/null
+++ b/kontact_plugin/Makefile.am
@@ -0,0 +1,18 @@
+INCLUDES = -I$(top_srcdir)/src -I$(top_builddir)/src -I$(top_srcdir) $(all_includes)
+
+kde_module_LTLIBRARIES = libkontact_basket.la
+libkontact_basket_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN)
+libkontact_basket_la_LIBADD = -lkpinterfaces -lDCOP -lqt-mt -lkdecore -lkdeui
+
+noinst_HEADERS = basket_plugin.h uniqueapphandler.h
+libkontact_basket_la_SOURCES = basket_plugin.cpp uniqueapphandler.cpp basketdcopiface.stub
+
+METASOURCES = AUTO
+
+basketdcopiface_DIR = $(top_srcdir)/src
+
+servicedir = $(kde_servicesdir)/kontact
+service_DATA = basket.desktop basket_v4.desktop
+
+basketsetdlgdir = $(kde_datadir)/kontact/ksettingsdialog
+basketsetdlg_DATA = kontact_basketplugin.setdlg