summaryrefslogtreecommitdiffstats
path: root/translations/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'translations/Makefile.am')
-rw-r--r--translations/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/translations/Makefile.am b/translations/Makefile.am
new file mode 100644
index 0000000..7a4c458
--- /dev/null
+++ b/translations/Makefile.am
@@ -0,0 +1,30 @@
+# make messages.pot
+# the -x is for skipping messages already translated in tdelibs
+
+messages:
+ echo Preparing documentation files handbook.pot and howto.pot...
+ mkdir -p tmp/
+ for XML_FILE in `cd ..; find docs -name "*.docbook"`; do\
+ echo " creating temporary POT file tmp/$$XML_FILE.pot";\
+ (cd tmp; mkdir -p `dirname $$XML_FILE.pot`; xml2pot ../../$$XML_FILE > $$XML_FILE.pot;)\
+ done
+ echo merging POT files...
+ msgcat --force-po -o handbook.pot `find tmp/docs/handbook -name "*.pot"`
+ msgcat --force-po -o howto.pot `find tmp/docs/howto/ -name "*.pot"`
+ rm -r ./tmp/
+ echo Finished creating handbook.pot and howto.pot.\n
+ echo Preparing program messages file messages.pot...
+ echo Before we start, run make to generate all the auto-generated .cpp and .h files
+ (sleep 5; cd ..; make) #needed for .ui files
+ echo Now extract the messages...
+ perl ./extractrc ../bibletime/xml/*.rc > ../bibletime/rc-dummy.cpp
+ perl ./preparetips ../docs/tips > ../bibletime/tips-dummy.cpp
+ $(XGETTEXT) -C -F -L C++ -ki18n -kI18N_NOOP -x `tde-config --prefix`/include/tde/kde.pot `find .. -type f -not -name clanguagemgr.cpp -and -name \*.cpp -or -name \*.h -or -name \*.cc` -o messages.pot
+ recode iso8859-1..utf-8 messages.pot
+ cp ../bibletime/backend/clanguagemgr.cpp clanguagemgr.cpp
+ $(XGETTEXT) --from-code=utf-8 --join-existing -C -F -L C++ -ki18n -kI18N_NOOP -x `tde-config --prefix`/include/tde/kde.pot clanguagemgr.cpp -o messages.pot
+ rm clanguagemgr.cpp
+ echo Finished creating messages.pot.
+
+
+