summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-02-10 16:22:59 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-02-10 16:23:37 +0100
commit2aebb287fa8672fd2a8b461c0eee6f020776c5c3 (patch)
treefa36e0e332895476ccead28104c568ec91ec700b /CMakeLists.txt
parente404567f7756495e486bda95b43dc68e3b1b5486 (diff)
downloaddolphin-2aebb287fa8672fd2a8b461c0eee6f020776c5c3.tar.gz
dolphin-2aebb287fa8672fd2a8b461c0eee6f020776c5c3.zip
cmake: Add rules to build documentation and translations.
This partially resolves issue #2. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 707a1272fc03fdc92279d73e702cb1bd51f89aa2)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 384b3e9..6b2bf44 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -45,6 +45,13 @@ tde_setup_paths( )
# option( WITH_LIBVISUAL "Enable libvisual support" OFF )
+##### user requested modules
+
+option( BUILD_ALL "Build all" ON )
+option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+
+
##### configure checks ##########################
include( ConfigureChecks.cmake )
@@ -64,6 +71,8 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### source directories ########################
add_subdirectory( src )
+tde_conditional_add_subdirectory( BUILD_DOC doc )
+tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )
##### write configure files #####################