summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFabio Rossi <rossi.f@inwind.it>2018-12-17 17:07:37 +0100
committerFabio Rossi <rossi.f@inwind.it>2018-12-17 17:07:37 +0100
commit88119a94df89384d9d6be4596219ed481a07359e (patch)
tree1c748428872ad7d2a13c11e5bd6f46a1c6794fcb /CMakeLists.txt
parentc6696eb3d3e2263d702e37f9b7c8ca3a8e945fec (diff)
downloaddolphin-88119a94df89384d9d6be4596219ed481a07359e.tar.gz
dolphin-88119a94df89384d9d6be4596219ed481a07359e.zip
Avoid overriding user linker flags (LDFLAGS) for modules and shared libs
Signed-off-by: Fabio Rossi <rossi.f@inwind.it>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9ad12f5..384b3e9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -57,8 +57,8 @@ add_definitions(
)
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
-set( CMAKE_SHARED_LINKER_FLAGS "-Wl,--no-undefined" )
-set( CMAKE_MODULE_LINKER_FLAGS "-Wl,--no-undefined" )
+set( CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined" )
+set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined" )
##### source directories ########################