summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6b2bf44..cdb1c0d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,6 +15,7 @@ cmake_minimum_required( VERSION 2.8 )
##### general package setup #####################
project( dolphin )
+set( VERSION R14.1.0 )
##### include essential cmake modules ###########
@@ -40,9 +41,10 @@ include( TDESetupPaths )
tde_setup_paths( )
-##### optional stuff ############################
+##### optional stuff
-# option( WITH_LIBVISUAL "Enable libvisual support" OFF )
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
##### user requested modules
@@ -59,9 +61,7 @@ include( ConfigureChecks.cmake )
###### global compiler settings #################
-add_definitions(
- -DHAVE_CONFIG_H
-)
+add_definitions( -DHAVE_CONFIG_H )
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
set( CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined" )