summaryrefslogtreecommitdiffstats
path: root/libk3b/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Golubev <fatzer2@gmail.com>2016-02-25 08:38:55 +0300
committerSlávek Banko <slavek.banko@axis.cz>2016-03-12 17:46:51 +0100
commitc51cb79dc03f550630d0b662900d2394817bae4e (patch)
treef2ad70d71d6449fa412a2fe0ce062cdcca4278bb /libk3b/tools/CMakeLists.txt
parent49c75bd470722fedbee23120cf5f4206c744debd (diff)
downloadk3b-c51cb79dc03f550630d0b662900d2394817bae4e.tar.gz
k3b-c51cb79dc03f550630d0b662900d2394817bae4e.zip
cmake: install library headers
(cherry picked from commit 333e6734554a3979f7d417fa1a27d3512cde3c60)
Diffstat (limited to 'libk3b/tools/CMakeLists.txt')
-rw-r--r--libk3b/tools/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/libk3b/tools/CMakeLists.txt b/libk3b/tools/CMakeLists.txt
index cd24070..99b0573 100644
--- a/libk3b/tools/CMakeLists.txt
+++ b/libk3b/tools/CMakeLists.txt
@@ -44,3 +44,22 @@ tde_add_library( k3btools STATIC_PIC AUTOMOC
k3bdirsizejob.cpp k3brichtextlabel.cpp k3btempfile.cpp k3bactivepipe.cpp
k3bfilesplitter.cpp k3bfilesysteminfo.cpp
)
+
+
+##### Headers ###################################
+
+install( FILES k3bwavefilewriter.h k3bbusywidget.h k3bdeviceselectiondialog.h
+ k3bmd5job.h k3bcutcombobox.h k3bstringutils.h
+ k3bdevicecombobox.h kcutlabel.h k3bstdguiitems.h
+ k3bvalidators.h k3bthroughputestimator.h k3biso9660.h
+ k3bmultichoicedialog.h k3bdevicehandler.h k3bcdparanoialib.h
+ k3blistview.h k3bmsfedit.h k3bcdtextvalidator.h
+ k3bintvalidator.h k3bexceptions.h k3bprogressdialog.h
+ k3btoolbox.h k3bpushbutton.h k3blistviewitemanimator.h
+ k3bthreadwidget.h k3bradioaction.h k3bsignalwaiter.h
+ k3biso9660backend.h k3bpipe.h k3bdirsizejob.h
+ k3bchecksumpipe.h k3btoolbutton.h k3bintmapcombobox.h
+ k3brichtextlabel.h k3btempfile.h k3bactivepipe.h
+ k3bfilesplitter.h k3bfilesysteminfo.h
+ DESTINATION ${INCLUDE_INSTALL_DIR}
+)