summaryrefslogtreecommitdiffstats
path: root/k3bsetup/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'k3bsetup/CMakeLists.txt')
-rw-r--r--k3bsetup/CMakeLists.txt47
1 files changed, 47 insertions, 0 deletions
diff --git a/k3bsetup/CMakeLists.txt b/k3bsetup/CMakeLists.txt
new file mode 100644
index 0000000..5e01b91
--- /dev/null
+++ b/k3bsetup/CMakeLists.txt
@@ -0,0 +1,47 @@
+#################################################
+#
+# (C) 2016 Golubev Alexander
+# fatzer2 (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/libk3b/core
+ ${CMAKE_SOURCE_DIR}/libk3b/tools
+ ${CMAKE_SOURCE_DIR}/libk3bdevice
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+##### kcm_k3bsetup2 (kpart) #####################
+
+tde_add_kpart( kcm_k3bsetup2 AUTOMOC
+ SOURCES base_k3bsetup2.ui k3bsetup2.cpp
+ LINK k3b-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### k3bsetup ##################################
+
+install( PROGRAMS k3bsetup
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### other data ################################
+
+install( FILES k3bsetup2.desktop
+ DESTINATION ${APPS_INSTALL_DIR}/Settings/System
+)