summaryrefslogtreecommitdiffstats
path: root/libk3b/plugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libk3b/plugin/CMakeLists.txt')
-rw-r--r--libk3b/plugin/CMakeLists.txt48
1 files changed, 48 insertions, 0 deletions
diff --git a/libk3b/plugin/CMakeLists.txt b/libk3b/plugin/CMakeLists.txt
new file mode 100644
index 0000000..7aa0ae1
--- /dev/null
+++ b/libk3b/plugin/CMakeLists.txt
@@ -0,0 +1,48 @@
+#################################################
+#
+# (C) 2016 Golubev Alexander
+# fatzer2 (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/libk3b
+ ${CMAKE_SOURCE_DIR}/libk3b/core
+ ${CMAKE_SOURCE_DIR}/libk3bdevice
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+if ( WITH_SYSTEM_LIBSAMPLERATE )
+ include_directories ( ${LIBSAMPLERATE_INCLUDE_DIRS} )
+ link_directories ( ${LIBSAMPLERATE_LIBRARY_DIRS} )
+else ( )
+ add_subdirectory( libsamplerate )
+ include_directories( libsamplerate )
+ set ( LIBSUMPLERATE_LIBRARIES samplerate-static )
+endif ( )
+
+
+##### k3bplugin (static) ########################
+
+list( APPEND k3bplugin_SOURCES k3bplugin.cpp k3bpluginconfigwidget.cpp k3bpluginmanager.cpp
+ k3baudiodecoder.cpp k3baudioencoder.cpp k3baudioclient.cpp
+ k3baudioserver.cpp )
+# We have to manually moc the file due to there is no corresponding source
+tde_moc( k3bplugin_SOURCES k3bprojectplugin.h )
+
+tde_add_library( k3bplugin STATIC_PIC AUTOMOC
+ SOURCES ${k3bplugin_SOURCES}
+ LINK ${LIBSAMPLERATE_LIBRARIES}
+)