summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2018-10-19 02:35:22 +0200
committerSlávek Banko <slavek.banko@axis.cz>2018-10-19 02:55:24 +0200
commit3e2052d2d451a77852c362f6b8812f74f4648739 (patch)
treebda6cd517037cb3dc2329f482d5e34af5762f47a /CMakeLists.txt
parent5de3d21a4a5c8fd83f4d6867b538653ea5c7ac82 (diff)
downloadkbiff-3e2052d2d451a77852c362f6b8812f74f4648739.tar.gz
kbiff-3e2052d2d451a77852c362f6b8812f74f4648739.zip
cmake: Add options WITH_SSL and WITH_MLED
Fix test for SSL => is not needed, because is used KSSL from tdelibs Fix test for ASUS Mail LED support in ACPI Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c94156e..a593098 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -42,6 +42,8 @@ tde_setup_paths( )
option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
+option( WITH_SSL "Build with SSL (imap4s and pop3s) protocol support" ${WITH_ALL_OPTIONS} )
+option( WITH_MLED "Compile with support for Mail LED on ASUS notebooks" OFF )
##### user requested modules
@@ -51,6 +53,11 @@ option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+##### user defined options #######
+
+set( _PATH_MAILDIR "/var/spool/mail" CACHE STRING "Path for the mail spool" )
+
+
##### configure checks
include( ConfigureChecks.cmake )