summaryrefslogtreecommitdiffstats
path: root/kbiff/Makefile.am
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2013-07-02 18:32:11 +0200
committerSlávek Banko <slavek.banko@axis.cz>2013-07-02 18:32:11 +0200
commit5ec5bc2080bbc41e025fb98e6571a2c281b775cb (patch)
treea73cf2c57d306e6ce092996f70b29b8fbc0a006b /kbiff/Makefile.am
downloadkbiff-5ec5bc2080bbc41e025fb98e6571a2c281b775cb.tar.gz
kbiff-5ec5bc2080bbc41e025fb98e6571a2c281b775cb.zip
Initial import
Diffstat (limited to 'kbiff/Makefile.am')
-rw-r--r--kbiff/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/kbiff/Makefile.am b/kbiff/Makefile.am
new file mode 100644
index 0000000..b2f6603
--- /dev/null
+++ b/kbiff/Makefile.am
@@ -0,0 +1,38 @@
+# just set the variable
+appsdir = $(kde_appsdir)/Internet
+apps_DATA = kbiff.desktop
+
+# set the include path for X, qt and KDE
+INCLUDES = $(all_includes)
+
+# claim, which subdirectories you want to install
+SUBDIRS = pics
+
+####### This part is very kbiff specific
+# you can add here more. This one gets installed
+bin_PROGRAMS =
+lib_LTLIBRARIES =
+kdeinit_LTLIBRARIES = kbiff.la
+
+# Which sources should be compiled for kbiff.
+kbiff_la_SOURCES = setupdlg.cpp kbiff.cpp main.cpp kbiffmonitor.cpp \
+ notify.cpp kbiffurl.cpp status.cpp kbiffcodec.cpp \
+ led.cpp kbiffcrypt.cpp version.cpp
+
+# the library search path
+kbiff_la_LDFLAGS = $(all_libraries) -module -avoid-version
+
+# the libraries to link against. Be aware of the order. First the libraries,
+# that depend on the following ones.
+kbiff_la_LIBADD = $(LIB_KFILE) $(LIB_KIO)
+
+# this option you can leave out. Just, if you use "make dist", you need it
+noinst_HEADERS = setupdlg.h kbiff.h kbiffmonitor.h notify.h kbiffurl.h \
+ status.h kbiffcodec.h led.h version.h
+
+METASOURCES = AUTO
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/kbiff.pot
+
+KDE_ICON = kbiff