summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am47
1 files changed, 0 insertions, 47 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
deleted file mode 100644
index 652db77..0000000
--- a/src/Makefile.am
+++ /dev/null
@@ -1,47 +0,0 @@
-## Makefile.am for bookreader
-
-# this is the program that gets installed. it's name is used for all
-# of the other Makefile.am variables
-bin_PROGRAMS = bookreader bookreader_client
-
-# set the include path for X, qt and KDE
-INCLUDES = $(all_includes)
-
-# the library search path.
-bookreader_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_TQT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_TDEIO) -ltdetexteditor
-
-# the libraries to link against.
-bookreader_LDADD = $(LIB_TDEFILE) $(LIB_TDEPRINT)
-
-# which sources should be compiled for bookreader
-bookreader_SOURCES = main.cpp bookreader.cpp bookreaderiface.skel \
- bookwidget.cpp theme.cpp settings.kcfgc settingsdlg.ui renderer.cpp bookmark.cpp \
- bookmarksdlg.cpp
-
-# these are the headers for your project
-noinst_HEADERS = bookreader.h bookwidget.h theme.h renderer.h bookmark.h \
- bookmarksdlg.h
-
-# client stuff
-bookreader_client_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_TQT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_TDEIO) -ltdetexteditor
-bookreader_client_LDADD = $(LIB_TDECORE)
-bookreader_client_SOURCES = bookreader_client.cpp
-
-kde_kcfg_DATA = bookreader.kcfg
-
-# let automoc handle all of the meta source files (moc)
-METASOURCES = AUTO
-
-messages: rc.cpp
- $(EXTRACTRC) `find . -name \*.ui -o -name \*.rc` > rc.cpp
- $(XGETTEXT) *.cpp -o $(podir)/bookreader.pot
-
-KDE_ICON = AUTO
-
-# this is where the kdelnk file will go
-kdelnkdir = $(kde_appsdir)/Office
-kdelnk_DATA = bookreader.desktop
-
-# this is where the XML-GUI resource file goes
-rcdir = $(kde_datadir)/bookreader
-rc_DATA = bookreaderui.rc