summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-07-26 16:52:47 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-07-26 16:52:47 +0200
commit99621e5d979d4ac4afd98af76507f5db48761135 (patch)
tree66299a74b550992a2d2ec9dedca420e5dc07f8c2 /CMakeLists.txt
parentee157d08c3a0dc403896d8989c3d13bfe5698df4 (diff)
downloadkcmautostart-99621e5d979d4ac4afd98af76507f5db48761135.tar.gz
kcmautostart-99621e5d979d4ac4afd98af76507f5db48761135.zip
Use common rules for build and install documentation and translations.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a559f4b..ff51837 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -69,10 +69,13 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( src )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
+##### other data ################################
+
+tde_conditional_add_project_docs( BUILD_DOC )
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
+
##### write configure files