summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-03-14 00:44:07 +0100
committerSlávek Banko <slavek.banko@axis.cz>2021-03-14 17:34:48 +0100
commit25cb1249e4fe72eec2474dc4d4c1e21605f52dc1 (patch)
tree3b199e61fa6052e51cdec6edc02bf76ce9d1a241 /CMakeLists.txt
parent869f7d92e154f33fb30d60fd4558c289f4178e95 (diff)
downloadkdbg-25cb1249e4fe72eec2474dc4d4c1e21605f52dc1.tar.gz
kdbg-25cb1249e4fe72eec2474dc4d4c1e21605f52dc1.zip
Added controlled conversions to char* instead of automatic ascii conversions.
The definition of -UTQT_NO_ASCII_CAST is no longer needed. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 627fc0ed620c1942afea9483bfaba794418d0300)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ce54f52..316325e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -62,7 +62,7 @@ include( ConfigureChecks.cmake )
###### global compiler settings
-add_definitions( -DHAVE_CONFIG_H -UQT_NO_ASCII_CAST )
+add_definitions( -DHAVE_CONFIG_H )
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
set( CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined" )