summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2021-03-14 00:37:49 +0100
committerSlávek Banko <slavek.banko@axis.cz>2021-03-14 17:34:27 +0100
commit869f7d92e154f33fb30d60fd4558c289f4178e95 (patch)
treee9dce66bc8df7e726d96e37a3d6448ab27b4a66b /CMakeLists.txt
parent0ec802b1628ffdac91ec87714bf5aaf769ce213e (diff)
downloadkdbg-869f7d92e154f33fb30d60fd4558c289f4178e95.tar.gz
kdbg-869f7d92e154f33fb30d60fd4558c289f4178e95.zip
Update the use of TQRegExp so that it does not require an old API.
The definition of -UTQT_NO_COMPAT is no longer needed. Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it> Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 4b34cf6bede5edd2537783e64f61511c7e5df755)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ebb510b..ce54f52 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -62,7 +62,7 @@ include( ConfigureChecks.cmake )
###### global compiler settings
-add_definitions( -DHAVE_CONFIG_H -UQT_NO_ASCII_CAST -UQT_NO_COMPAT )
+add_definitions( -DHAVE_CONFIG_H -UQT_NO_ASCII_CAST )
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
set( CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined" )