summaryrefslogtreecommitdiffstats
path: root/kdbg.spec
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2013-07-03 02:27:05 +0200
committerSlávek Banko <slavek.banko@axis.cz>2013-07-04 04:29:04 +0200
commitdaeb1d9355e1321b88534dc56d2870822e468fdb (patch)
tree15cc7567f5fb7a770bd60e909b272bab5d719a7a /kdbg.spec
parent9dab0e253ecf583a2cc6ca22e068d4f4022ca4d3 (diff)
downloadkdbg-daeb1d9355e1321b88534dc56d2870822e468fdb.tar.gz
kdbg-daeb1d9355e1321b88534dc56d2870822e468fdb.zip
Initial TDE conversion
Diffstat (limited to 'kdbg.spec')
-rw-r--r--kdbg.spec14
1 files changed, 7 insertions, 7 deletions
diff --git a/kdbg.spec b/kdbg.spec
index 0508ea2..0d78255 100644
--- a/kdbg.spec
+++ b/kdbg.spec
@@ -17,7 +17,7 @@ Vendor: Johannes Sixt <j6t@kdbg.org>
Packager: Ullrich von Bassewitz <uz@musoftware.de>
Source: %{name}-%{version}.tar.gz
URL: http://www.kdbg.org/
-Requires: kdelibs >= 2.0
+Requires: tdelibs >= 2.0
BuildRoot: /tmp/build-%{name}-%{version}
%description
@@ -33,17 +33,17 @@ rm -rf %{builddir}
touch `find . -type f`
%build
-if [ -z "$KDEDIR" ]; then
- export KDEDIR=%{prefix}
+if [ -z "$TDEDIR" ]; then
+ export TDEDIR=%{prefix}
fi
CXXFLAGS="$RPM_OPT_FLAGS" CFLAGS="$RPM_OPT_FLAGS" ./configure \
- --prefix=$KDEDIR
+ --prefix=$TDEDIR
make
%install
-if [ -z "$KDEDIR" ]; then
- export KDEDIR=%{prefix}
+if [ -z "$TDEDIR" ]; then
+ export TDEDIR=%{prefix}
fi
rm -rf $RPM_BUILD_ROOT
make DESTDIR=$RPM_BUILD_ROOT install-strip
@@ -56,7 +56,7 @@ find . -type f | sed -e 's,^\.,\%attr(-\,root\,root) ,' \
$RPM_BUILD_DIR/file.list.%{name}
find . -type l | sed 's,^\.,\%attr(-\,root\,root) ,' >> \
$RPM_BUILD_DIR/file.list.%{name}
-echo "%docdir $KDEDIR/share/doc/HTML" >> $RPM_BUILD_DIR/file.list.%{name}
+echo "%docdir $TDEDIR/share/doc/HTML" >> $RPM_BUILD_DIR/file.list.%{name}
%clean