summaryrefslogtreecommitdiffstats
path: root/ConfigureChecks.cmake
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-02-11 23:07:07 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-02-11 23:07:07 +0100
commitfd4fdb5e2f3a3acf54d842707cc673e541cda696 (patch)
tree8345caec95c106ccd415542d5448ee99414c9c07 /ConfigureChecks.cmake
parentb99ceb4eac0975d2319a7ab7e0c7a161cee238c8 (diff)
downloadkgtk-qt3-fd4fdb5e.tar.gz
kgtk-qt3-fd4fdb5e.zip
Use common CMake tests.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'ConfigureChecks.cmake')
-rw-r--r--ConfigureChecks.cmake33
1 files changed, 14 insertions, 19 deletions
diff --git a/ConfigureChecks.cmake b/ConfigureChecks.cmake
index 4eff805..1149770 100644
--- a/ConfigureChecks.cmake
+++ b/ConfigureChecks.cmake
@@ -9,27 +9,26 @@
#
#################################################
+
+# required stuff
+find_package( TQt )
+find_package( TDE )
+
+tde_setup_architecture_flags( )
+
+include(TestBigEndian)
+test_big_endian(WORDS_BIGENDIAN)
+
+tde_setup_largefiles( )
+
+
##### check for gcc visibility support #########
-# FIXME
-# This should check for [T]Qt3 visibility support
if( WITH_GCC_VISIBILITY )
- if( NOT UNIX )
- tde_message_fatal(FATAL_ERROR "\ngcc visibility support was requested, but your system is not *NIX" )
- endif( NOT UNIX )
- set( __KDE_HAVE_GCC_VISIBILITY 1 )
- set( CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fvisibility=hidden -fvisibility-inlines-hidden")
- set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fvisibility=hidden -fvisibility-inlines-hidden")
+ tde_setup_gcc_visibility( )
endif( )
-if( BUILD_TRANSLATIONS AND NOT DEFINED MSGFMT_EXECUTABLE )
- find_program( MSGFMT_EXECUTABLE msgfmt )
- if( NOT MSGFMT_EXECUTABLE )
- tde_message_fatal( "msgfmt program is required, but was not found on your system" )
- endif( )
-endif( )
-
check_type_size( "int" SIZEOF_INT BUILTIN_TYPES_ONLY )
check_type_size( "long" SIZEOF_LONG BUILTIN_TYPES_ONLY )
@@ -67,7 +66,3 @@ if ( BUILD_KGTK_GTK2 )
message("** INFORMATION: You're libdl does not contain dlvsym - SWT apps will not be supported")
endif(LIBDLVSYM_LIBRARY)
endif ()
-
-# common required stuff
-find_package( TQt )
-find_package( TDE )