summaryrefslogtreecommitdiffstats
path: root/kdialogd3/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-10-18 23:39:52 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-10-18 23:56:58 +0200
commit5728ee11b05c6ab177c8a5d4a5330b210a22e927 (patch)
treeca44a27c6cc0ed15cdee1916b77e9ce42bbfc5a5 /kdialogd3/CMakeLists.txt
parentff093aacb444803e5d7f3945e33e8ab1525544b4 (diff)
downloadkgtk-qt3-5728ee11b05c6ab177c8a5d4a5330b210a22e927.tar.gz
kgtk-qt3-5728ee11b05c6ab177c8a5d4a5330b210a22e927.zip
Housekeeping in CMake rules:
+ Removed detailed DL library detection - the results were not used. + Added test whether the DL library contains _dl_sym function. + GTK presence test moved to ConfigureChecks.cmake. + Added GTHREAD presence test. + Used tde_add_library macro. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 06e967574741ce2f3b29ba4ed4d5e2629c47553c)
Diffstat (limited to 'kdialogd3/CMakeLists.txt')
-rw-r--r--kdialogd3/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/kdialogd3/CMakeLists.txt b/kdialogd3/CMakeLists.txt
index d56ee22..3f2c5e1 100644
--- a/kdialogd3/CMakeLists.txt
+++ b/kdialogd3/CMakeLists.txt
@@ -23,7 +23,6 @@ link_directories(
${TDE_LIBRARY_DIRS}
)
-message("** INFORMATION: KDialogD for TDE will be built.")
##### kdialogd3 (executable) #################
@@ -37,4 +36,4 @@ tde_add_executable( ${target} AUTOMOC
SOURCES ${${target}_SRCS}
LINK tdecore-shared tdeui-shared tdeio-shared
DESTINATION ${BIN_INSTALL_DIR}
-) \ No newline at end of file
+)