summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-07-26 10:36:35 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-07-26 10:36:51 +0200
commitf67febb9bb6eb2ff9eb5e5774f0fe84ccf85b018 (patch)
treea32ede2c3fa8ec40c230f89eae2c09bee599b458 /CMakeLists.txt
parent701a618d1a64bfaaa134e86ae6114b444dae8df1 (diff)
downloadkiosktool-f67febb9bb6eb2ff9eb5e5774f0fe84ccf85b018.tar.gz
kiosktool-f67febb9bb6eb2ff9eb5e5774f0fe84ccf85b018.zip
Use common rules for build and install documentation and translations.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 6829385342ddce5d89bb36c33f3210c01fbc43f4)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6a22033..24669fc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -71,10 +71,13 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( ${PROJECT_NAME} )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
+##### other data ################################
+
+tde_conditional_add_project_docs( BUILD_DOC )
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
+
##### write configure files