summaryrefslogtreecommitdiffstats
path: root/po/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2018-12-13 02:36:49 +0100
committerSlávek Banko <slavek.banko@axis.cz>2018-12-13 02:37:51 +0100
commit5f8d3c3fd4af27b63940d85b46f5e2b21f17e66c (patch)
treeb468634c628ece7edaaa7db36f17fd5abe0f328e /po/CMakeLists.txt
parenta6e34bb9beafea3f18280ddcf8bf971bbb3bebba (diff)
downloadkiosktool-5f8d3c3fd4af27b63940d85b46f5e2b21f17e66c.tar.gz
kiosktool-5f8d3c3fd4af27b63940d85b46f5e2b21f17e66c.zip
Add CMakeL10n rules.
Create translation template. Modify CMake rules for translations to make them independent of languages. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit d754910274408fa59eceedd1bba3339df800de1c)
Diffstat (limited to 'po/CMakeLists.txt')
-rw-r--r--po/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
index 6d0aa9f..2ce6ef4 100644
--- a/po/CMakeLists.txt
+++ b/po/CMakeLists.txt
@@ -1 +1,9 @@
-tde_auto_add_subdirectories( )
+# build translations if some are already available
+
+file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} ${PROJECT_NAME}.po )
+
+foreach( _po ${po_files} )
+ string( REPLACE "/" ";" _path "${_po}" )
+ list( GET _path 0 _lang )
+ tde_create_translation( FILES ${_po} LANG ${_lang} )
+endforeach( )