summaryrefslogtreecommitdiffstats
path: root/kiosktool/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kiosktool/Makefile.am')
-rw-r--r--kiosktool/Makefile.am62
1 files changed, 62 insertions, 0 deletions
diff --git a/kiosktool/Makefile.am b/kiosktool/Makefile.am
new file mode 100644
index 0000000..915f197
--- /dev/null
+++ b/kiosktool/Makefile.am
@@ -0,0 +1,62 @@
+## Makefile.am for kiosktool
+
+# this has all of the subdirectories that make will recurse into. if
+# there are none, comment this out
+SUBDIRS = . kcms
+
+# this is the program that gets installed. it's name is used for all
+# of the other Makefile.am variables
+bin_PROGRAMS = kiosktool kiosktool-kdedirs
+
+# set the include path for X, qt and KDE
+INCLUDES = $(all_includes)
+
+# the library search path.
+kiosktool_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+
+# the libraries to link against.
+kiosktool_LDADD = $(LIB_KFILE) -lkdeprint
+
+# which sources should be compiled for kiosktool
+kiosktool_SOURCES = main.cpp kioskgui.cpp kioskdata.cpp kioskrun.cpp \
+ mainview.ui profileSelectionPage_ui.ui \
+ profilePropsPage.cpp profilePropsPage_ui.ui \
+ pageWidget.cpp component.cpp \
+ desktopComponent.cpp menueditComponent.cpp screensaverComponent.cpp \
+ panelComponent.cpp filetypeeditComponent.cpp \
+ componentSelectionPage.cpp componentSelectionPage_ui.ui \
+ componentPage.cpp componentPage_ui.ui \
+ userManagement.cpp userManagement_ui.ui userManagementGroup_ui.ui \
+ userManagementUser_ui.ui \
+ kioskConfigDialog.cpp kioskConfigDialog_ui.ui \
+ kiosksync.cpp
+
+# the library search path.
+kiosktool_kdedirs_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+
+# the libraries to link against.
+kiosktool_kdedirs_LDADD = $(LIB_KDECORE)
+
+# which sources should be compiled for kiosktool
+kiosktool_kdedirs_SOURCES = kiosktool-kdedirs.cpp
+
+# these are the headers for your project
+noinst_HEADERS = kioskgui.h
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+messages: rc.cpp
+ ./extractxml kiosk_data.xml > kiosk_data.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kiosktool.pot
+ rm kiosk_data.cpp
+
+KDE_ICON = kiosktool
+
+xdg_apps_DATA = kiosktool.desktop
+
+# this is where the XML-GUI resource file goes
+rcdir = $(kde_datadir)/kiosktool
+rc_DATA = kiosktoolui.rc kiosk_data.xml caption.png background.png logo.png \
+ caption-da.png caption-empty.png caption-et.png caption-pt.png caption-pt_BR.png \
+ caption-sv.png